How to change tegra18_defconfig

I am trying to use an Easycap driver for analog to usb camera conversion to use with TX2 , I am using jetpack 3.3/3.2/3.1 which comese with kernel version 4.4 . The Easycap driver uses a STK1160 chip and the driver for the chip is already in the mainline kernel from version 2.6 . So when i plug in it detects there is a new usb device in the system . But nothing appears like /dev/video1 or 2 or anything . So I checked the L4t sources and STK1160 is not included in kernel configuration, so it was never compiled at the first place . so I tried to compile the kernel and after " make tegra18_defconfig " i ran “make menuconfig” and i didnt find any option for STK1160 .

Now how do i change defconfig so it includes the STK1160 driver which is located in driver/media/usb/stk1160 directory . I actually tried just editing tegra18_defconfig in arch/arm64/configs directory and added “CONFIG_VIDEO_STK1160=y/m” and then ran "make tegra18_defconfig " , then i checked the .config file which didnt include the line in .config file .
so My question would be how do i include the driver in configuration so it get compiled .

Kind regards

I don’t know about that particular driver, but instead of tegra18_defconfig I suggest starting with what the running system has. You can copy “/proc/config.gz” somewhere, gunzip it, and add the correct CONFIG_LOCALVERSION…then you will have an exact match of what is running and a rename to “.config” will start whichever config editor you use right where you need to start. The “make nconfig” configuration editor has the advantage there that you can search for symbols, e.g., perhaps search for “stk1160”. See:
https://devtalk.nvidia.com/default/topic/1038175/jetson-tx2/tx2i-wifi-support/post/5274619/#5274619