How to change the back-clipping?

See the video above:

How to to change the back-clipping - make it larger? So when I scale up the landscape terrain to correct size it would not cut it off?

I know I can scale down the houses but then navigating with viewport gets harder, the middle mouse zoom in / out steps are like 5-10 meters, huge jumps…

Hey! When I created new camera from current view ( so start animating it ) this problem disappeared.

@pekka.varis It looks like you’re hitting the far limit of the clipping plane Clipping Range for the perspective camera.

To change it, select the options box for the perspective camera.

Screenshot 2021-05-24 112158

Then input a larger number into the far limit of the Clipping Range until all of your meshes are visible.

Screenshot 2021-05-24 112347

Hey, I see that settings in Clipping range Y higher than 10000000 does not have any effect. It is the MAX. I can live with this, just have to learn the basics of navigation: Navigation Basics in Omniverse Create - YouTube

Pekka