How to change the NX debug UART/ttyTHS1 to a general UART function?

We need to use 2xUARTs to communicate with our devices.

  1. Pin99/101 UART0/ttyTHS0 works fine.
  2. Pin236/238 UART2/ttyTHS1 default function is debug console and we tried to disable the console function without ‘console-port’, but still failed.
  3. Can you help to give the guide to change ttyTHS1 as a general UART port.
$dmesg | grep 'tty'
[    1.457214] 3100000.serial: ttyTHS0 at MMIO 0x3100000 (irq = 47, base_baud = 0) is a TEGRA_UART
[    1.458631] 3110000.serial: ttyTHS1 at MMIO 0x3110000 (irq = 48, base_baud = 0) is a TEGRA_UART
[    1.459492] 3140000.serial: ttyTHS4 at MMIO 0x3140000 (irq = 49, base_baud = 0) is a TEGRA_UART
[    1.460844] console [ttyTCU0] enabled
  1. We modified dtsi file hardware\nvidia\platform\t19x\jakku\kernel-dts\common\tegra194-p3668-common.dtsi as follow:
serial@3100000 {
	compatible = "nvidia,tegra186-hsuart";
	status = "okay";

serial@3140000 {
	compatible = "nvidia,tegra186-hsuart";
	status = "okay";

combined-uart {
	status = "okay";
  1. If we changed ‘enable_combined_uart’ and ‘spe_uart_instance’, the NX can’t boot up.
enable_combined_uart = 0;
spe_uart_instance = 0xff;


Thanks so much.

hello Ciya.Jiang,

could you please check similar discussion thread, Topic 145106 for reference,

Hi JerryChang,

I have checked and followed this topic, but this topic wasn’t solved his problem?

here’re steps to disable debug console.

  1. please refer to cfg file,
  2. please have modification to update “Verbosity” property,
    for example,
    Verbosity = 0; # 0: Disabled: 1: Critical, 2: Error, 3: Warn, 4: Info, 5: Debug
  3. you may flash the board to update board configure file,
    for example,
    $ sudo ./flash jetson-xavier mmcblk0p1

hello Ciya.Jiang,

there’re 3 UARTs available,
UART0 to M2
UART1 to 40PIN
UART2 to debug

may I know what’s your mean about changing the NX debug UART/ttyTHS1 to a general UART function.

Hi JerryChang,

We want to use UART2(debug) as a general uart such as UART1(40PIN) function and don’t need uart for debug information.


hello Ciya.Jiang,

please refer to documentation, please modify environment configuration to Disable Console over UART.

hello, @Luna2020

Disable Console over UART is marked as solution here, but my test is failed, do you really success to use UART2(debug) as a general uart such as UART1(40PIN) ?

Hi suchb,

I tried saveral methods but no one works fine, so I abandoned it.

@JerryChang Hi,Jerry

Could you please show the detailed steps to use ttyTCU0 and ttyTHS0 as a general uart such as UART1(40PIN) ?
by following developer guide or related topics,all my test is failed.

hello suchb,

let’s follow-up this in Topic 170116 for further supports.