How to change the otg mode of usb to host in jetson r35.4.1

We used jeston agx orin, version r35.4.1. On the hardware, the type C of usb is changed to type A, and the working mode is expected to be changed from OTG to host. What changes need to be made to which files in the device tree to make the usb drive work properly?

refer to the document here.
https://docs.nvidia.com/jetson/archives/r35.4.1/DeveloperGuide/text/HR/JetsonModuleAdaptationAndBringUp/JetsonAgxOrinSeries.html?highlight=universal#porting-the-universal-serial-bus

I have modified common/tegra194-e3366-1199-a00.dtsi according to the link you sent as follows, but after burning and writing, usb is still not available. Hope to provide more detailed help.

— a/common/tegra194-e3366-1199-a00.dtsi
+++ b/common/tegra194-e3366-1199-a00.dtsi
xusb_padctl: xusb_padctl@3520000 {

ports {
usb2-0 {
– mode = “otg”;
++ mode = “host”;
status = “okay”;
#if TEGRA_XUSB_DT_VERSION >= DT_VERSION_3
usb-role-switch;
connector {
– compatible = “usb-b-connector”, “gpio-usb-b-connector”;
++ compatible = “gpio-usb-b-connector”;
label = “micro-USB”;
type = “micro”;
– vbus-gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(M, 3) GPIO_ACTIVE_LOW>;
++ vbus-gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(M, 3) GPIO_ACTIVE_HIGH>;

– id-gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(Q, 0) GPIO_ACTIVE_HIGH>;
++ id-gpio = <&tegra_main_gpio TEGRA194_MAIN_GPIO(Q, 0) GPIO_ACTIVE_LOW>;
};
endif
};

};

  1. 你得先把Xavier AGX上面的type C controller關掉. 把關聯的node都拿掉

  2. 我看不懂你這個patch除了把otg改成host之外改了什麼 . id-gpio是拿掉了還是沒有拿掉?

  3. Xavier AGX 原本的device tree上面就已經有一個port是typeA設定了, 你可以參考那個port的device tree把你要改的port改成類似的.

We are using jeston agx orin, jetson r35.4.1, can you provide some more detailed help?

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Is this still an issue to support?
Have you tried the suggestions that we mentioned above?
Any result can be shared?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.