How to clean userdata after upgrade the DriveOS from6.0.3 to 6.0.4

we follow the [NVIDIA DRIVE OS 6.0 Linux SDK Developer Guide] pdf file upgrade the driveOS from to after the upgrade we found the userdata isn’t clean. the nv-driveos-linux-xxxxxxx.deb package which we’ve install in the still exist. is there a way to reflash the sytem with a fully clear. cause we found after the DriveOS the eth card not works.
BTW our device’s SN is xxxxxxxxx-C00,we’ve tried both
./make/bind_partitions -b p3710-10-“a03” linux
and ./make/bind_partitions -b p3710-10-“a04” linux
same situation.

Please follow DRIVE OS 6.0 Installation Guide for NVIDIA Developers to install 6.0.4 with SDK Manager and tick “Force wipe” option in the below image.

hi, this is what I wonder. we’ve tried use sdk manager to reflash ,but not work. I have two account one is development account and the other is partner account. one can’t select Drive and the other can’t goto next step to flash. I don’t know if it is the account access issue. I’ve upload the snapshot. if is the access issue,how can we apply。

Please log in with your developer account, browse NVIDIA DRIVE® AGX SDK Developer Program | NVIDIA Developer, and then click “Join now” button.
After that, you can check if you can select DRIVE in SDK Manager.

Hi Vick,
thank you for your help. when I follow your advice,to open that web site
the information show that my account doesn’t have the access to join now. I’ve contract my NV window to ask for the access.

The account access’s issue has been solved. when I goto step 04 and ready to flash the device. sdk manager report the issue of can’t find a json file by /tmp/
I’ve checked the tmp folder the driveinstaller folder doesn’t exist.

also,i’ve attach the full log file,pls check that ,thanks! (110.7 KB)

We will check the logs and get back to you. Please also check if you met System Requirements.

we solved this issue. need uninstall the download file and reope the sdk manager

what did you mean uninstall the download file? remove ~/Downloads/nvidia/sdkm_downloads directory?

it’s just my experience. i don’t know if other guys can use this trick.
1.when first time met the flash fail DON’T use the RETRY. reboot the target and host and check the usb connection.
2. when used RETRY. and still failed. just move the sdkm_download to another folder and reinstall the sdk manager. and select the backup folder.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.