How to config ar0231@0x50 video0 work in 3 lane mode

Hi,
I want to config ar0231@0x50 video0 work in 3 lane,below is my dts file, I can not receive data from mipi,I can confirm camera work in 3 lane mode.
tegra194-p2888-0001-p2822-0000.txt (602.9 KB)

I don’t think there’s a sensor support 3 lanes DPHY configuration.
You can configurate by the bus-width in device tree for 1/2/4 lanes for DPHY.

Thanks

Hi,
I use a mipi generator device(not a sensor) to generate 3 lane mipi signal. So I think 3 lane mipi tx is ok. I want to know if xavier support 3 lane configuration.

Xavier DPHY don’t support 3 lanes.

Thanks

I change the dts config to 2 lane ,but I still can not receive mipi data .
Below is my modify,and the whole dts file .Please help me to analyze the problem.


tegra194-p2888-0001-p2822-0000.txt (602.9 KB)

Do you configure the mipi generator by 2 lanes too.
Check the trace log.

https://elinux.org/Jetson/l4t/Camera_BringUp#Steps_to_enable_more_debug_messages

Hi,
Now I can capture image from mipi generator in1 lane mode .
But I can not receive data from 1 lane sensor .
Below is the trace log.

The error tells SOT multiple error. Check the settle time.

Do you mean it is a hardware problem,or a configuration problem in xavier?So what should I do now,I find a settletime configuration in dts file,should I change this params .
image

No, I mean the sensor output signal need to follow the MIPI spec like above picture.

Ok I see.It is cause by mipi signal quality or sensor configuration? Do you mean I should change the sensor mipi dphy configuration.

There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.
Thanks

Is this still an issue to support? Any result can be shared?