How-To Configure Remote Monitor to use specific IP & Port?

How can I configure Nsight Remote Monitor to bind to a specific IP and port? In general what are the configuration parameters available to us launching Remove Monitor?


Currently we don’t support port reconfiguration, but the scanned range is 50352-50416 . Can you let us know what your use case is regarding the need to configure the monitor?

Kind Regards,


Issue arose with many of us working from home due to pandemic. Non-issue in normal work environment.

Use case is performing a remote GPU capture of machine on local network (192.168.x.x) but that is also employing VPN IP to corp office. When VPN is active a connection cannot be established to target machine for capture / analysis using Nsight toolset.

Nsight, a functional workaround is temporarily disabling VPN to perform and analyze capture.

PIX suffers from the same issue. In PIX case disabling VPN, starting PIX monitor, re-enabling VPN, is functional solution.

RenderDoc has no issues at all. This, I believe, is due to integration into Unreal Engine. Although I’m not certain of that.

There are many reasons not to perform this operation over VPN.


I will file a feature request for our engineering team to take action on this use case and get into a future release. I realize you need this feature now due to the pandemic. Hopefully, we can get this into the next release.

Best Regards,

@__Jamie I wanted to follow-up to ask about what your thoughts are around configuration. Would you anticipate that if we offered a port configuration that it would work around the issue? Also, I’m not sure how your machine’s ip changes once the VPN is active. When setting the remote connection, are you using a machine name and finding that it is resolving incorrectly or are you using a literal IP address?

Apologies for the delay, thought I had responded to this.

RenderDoc has been working well and have not tried latest NSight releases. Going back to original scenario, with respect to NSight the connection fails using hostname or 192.168.x…x, unless I disable VPN on remote machine.

While setting up a new VPN dev machine, the first launch of our build, Windows Firewall dialog pops up requesting network permission, I bet that’s why RenderDoc is working. Will try poking a hole in the firewall for the nsight monitor and see if that resolves.