How to Control a WS2812 LED through Jetson GPIO with python

I’m trying to control a WS2812 LED through Jetson GPIO. I was able to do it on a raspberry pi using this library(rpi_ws281x) . But I find it’s hard to do it on the Nano. I googled it and find too little information to help me.
Does anyone know how to solve this problem using Jetson GPIO?

Hi phdh4,

Are you using the devkit or custom board for Jetson Nano?
What’s your Jetpack version in use?

Which GPIO do you want to use?
Have you tried to control GPIO with sysfs successfully?

Hello Kevin,
I’m using the devkit and my jetpack version is 4.6.
I have tried Jetson.GPIO package with python3.6. And I also try to control WS2812 through with spidev package with python. But I all failed.

I’m closing this topic due to there is no update from you for a period, assuming this issue was resolved.
If still need the support, please open a new topic. Thanks

Could you help to update to latest JP4.6.3(R32.7.3) to verify?

How do you connect WS2812 to your Jetson Nano?
Which GPIO pin do you want to use?