How to create sd-blod.img in jetson orin nano devkit?

i’m trying to deploy a changed file system.
I checked several topics, but they seem to be created on the host PC.
Please let me know if there is a way to create sd-blod.img in jetson orin nano devkit??

Thank you.


Welcome to the NVIDIA Developer forums! This topic belongs in the Jetson category.

I will move it over for you.

1 Like

Please refer to Flashing Support — Jetson Linux Developer Guide documentation (


“ROOTFS_DIR=<MODIFIED_ROOTFS_PATH> ./ -o <blob_name> -b -r ” If entered, the error is “Making Boot image… failed”
If I look up the forum, I use this guide on my host PC, is it correct?
But, i want create sd-blob.img in jetson-orin-nano-devkit.
Could you tell me how?

Thank you.


The script calls some binaries that are compiled for x86 platforms, so they cannot be run on Jetson, which is based on ARM architectures.
The same applies for the fact that you cannot use a Jetson device for flashing another Jetson device.
For example:

./bootloader/mkbootimg: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), statically linked, for GNU/Linux 2.6.8, BuildID[sha1]=af11cc3c5344b225ba760dfc6150a7d0516a807c, with debug_info, not stripped

Thank you for your response.
Is there a way to transfer the changed rootfs content from jetson orin nano to the host PC as it is?

Thank you

Try something like this:

I’m tried to backup and created the image file.
but, Only the black screen is being output on the screen.
Can you give me your opinion on this?

Thank you

Is it working properly before backup?
Are you at least able to login via serial console?

Actually the official way is to use the backup/restore tool as indicated in Linux_for_Tegra/tools/backup_restore/.
You may miss something during backup, and we don’t verify the workflow you are trying now.

It works well before you back up also, the serial console works fine.
I will share the saved log with you.

log.txt (68.3 KB)

What do you get with lsmod?
Please also show me contents of /var/log/xorg.0.log and dmesg.

Please also try this.

Here is xorg.log and lsmod.
dmesg is the log.txt on top.
lsmod.txt (3.2 KB)
xorg.0.log.txt (13.6 KB)

I don’t know why this appeared in the Xorg log:

[    28.864] (WW) NVIDIA(GPU-0): Failed to enter interactive mode. 
[    28.877] (EE) NVIDIA(0): Failed to allocate NVIDIA Error Handler
[    28.877] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    28.877] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    28.877] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    28.877] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    28.877] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    28.877] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    28.877] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    28.877] (II) NVIDIA(0):     Config Options in the README.
[    28.914] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[    29.082] (==) NVIDIA(0): Disabling shared memory pixmaps
[    29.082] (==) NVIDIA(0): Backing store enabled
[    29.082] (==) NVIDIA(0): Silken mouse enabled
[    29.083] (==) NVIDIA(0): DPMS enabled

Maybe it’s caused by some permission issues of those driver stuff.
Please try and see if the backup/restore tool works.

Is the tool used by the host PC?

Put the device into force recovery mode and connect it to your host PC.

Do you have instructions on how to use the backup tool?

Refer to Linux_for_Tegra/tools/backup_restore/README_backup_restore.txt.
For example:

sudo ./tools/backup_restore/ -e mmcblk1 -b jetson-orin-nano-devkit
sudo ./tools/backup_restore/ -e mmcblk1 -r jetson-orin-nano-devkit

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.