How to debug a TX2 bootstrap trouble


When I tried to enable dual HDMI output, the TX2 module was in trouble.

Module: TX2 (P3310)
CarrierBoard: P2597

When I pressed the POWER BUTTON,I watched logs below on the serail-console.

[0001.946] C> MTS error (2) : dram alias check failure
[0001.951] C> cpu waypoint 0.5 failed
[0001.954] C> ERROR: Highest Layer Module = 0x32, Lowest Layer Module = 0x32,
Aux Info = 0x1, Reason = 0x6

And only these message here, the module stopped there.
What happened and how should I recover it please ?

Are you able to flash this board?


[   6.4414 ] 
[   6.4423 ] tegrahost_v2 --chip 0x18 --generateblob blob.xml blob.bin
[   6.4432 ] number of images in blob are 9
[   6.4436 ] blobsize is 3791992
[   6.4438 ] Added binary blob_nvtboot_recovery_cpu_sigheader.bin.encrypt of size 202832
[   6.4456 ] Added binary blob_nvtboot_recovery_sigheader.bin.encrypt of size 89184
[   6.4466 ] Added binary blob_preboot_d15_prod_cr_sigheader.bin.encrypt of size 63104
[   6.4477 ] Added binary blob_mce_mts_d15_prod_cr_sigheader.bin.encrypt of size 2082144
[   6.4484 ] Added binary blob_bpmp_sigheader.bin.encrypt of size 533056
[   6.4487 ] Added binary blob_tegra186-a02-bpmp-quill-p3310-1000-c04-00-te770d-ucm2_sigheader.dtb.encrypt of size 466240
[   6.4487 ] Added binary blob_tos-mon-only_sigheader.img.encrypt of size 83760
[   6.4487 ] Added binary blob_eks_sigheader.img.encrypt of size 1440
[   6.4487 ] Added binary blob_tegra186-quill-p3310-1000-c03-00-base_sigheader.dtb.encrypt of size 270080
[   6.4487 ] 
[   6.4487 ] Sending bootloader and pre-requisite binaries
[   6.4496 ] tegrarcm_v2 --download blob blob.bin
[   6.4503 ] Applet version 01.00.0000
[   6.4728 ] Sending blob
[   6.6532 ] 
Error: Return value 1
Command tegrarcm_v2 --download blob blob.bin
Failed to flash/read t186ref.

Which jeptack release are you using to flash?

We adopt jetpack 32.2.

Please try with rel32.5.1 to prevent the chance that it is caused by the PCN update.


I’ve tried 32.5.1. Maybe the sample root filesystem is not complete, the failed for lack of files. I modifed/added scripts/files to allow the go through with option “–no-flash”.

Failed to flash the device anyway, I think the module was corrupted.

I really appreciate your help.

Just try to use sdkmanager which would not have have rootfs problem.

What you’ve tried has no help for this issue. You modified the script and nobody knows what you are doing or what you’ve added. “–no-flash” is as its name, it does not flash the board.

I use “–no-flash” to build the system. When I flash the device, I removed it of course.

I’ll try sdkmanager later, before that, I must install ubuntu 16.04 on some PC.

Why do you have to install ubuntu 16.04 on some PC? Sdkmanager is using the same tool as what you are doing.

Aren’t you using a ubuntu machine when you tried with

Maybe these messages from serial console help

[0042.348] E> Blob is not set
[0042.486] E> Checksum verification failed.
[0042.490] E> Sending nack 0x0b85c11c
[0042.494] E> Failed to receive data
[0042.498] E> (0b85c11c): Failed to receive data from host

Just try to use sdkm first. If the host and uart log gives out the same error, then you can RMA this module.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.