How to delete l4tbr0 bridge

My TX2 keeps creating a bridge l4tbr0 with an ip address that happens to be on the same network that the jetson is on. This messes up the networking. If I change the IP in use by the bridge it resets on reboot. If I delete l4br0 and reboot it comes back. How can I delete this bridge forever?

I’ve never looked closely at this, but this seems to be a demo for the USB gadget setup. If you look at “/opt/nvidia/l4t-usb-device-mode/” you will find the start and stop scripts. These are set up as systemd services, and the customization which actually links them is in “/etc/systemd/system/”:

find /etc/systemd/system -name 'nv-l4t-usb-device-mode*'

These are symbolic links to the real files:

ls -l `find /etc/systemd/system -name 'nv-l4t-usb-device-mode*'`

Thus you can simply delete the symbolic links for the start and stop scripts within “/etc/systemd/system/”. To reactivate, just put the symbolic links back in.

I have wondered if perhaps this was intended to eventually work for package installs after a flash such that USB becomes a network and ethernet could be ignored. I’m curious, and glad I’m not a cat!

1 Like

removing the symbolic link for nv-l4t-usb-device-mode.service did not stop it from running at boot time.

Did you first run the “stop” and “disable” commands for systemctl? I have not tried this on my Jetson (removing files that is), but you can run this to find all related files:
sudo find /etc/systemd -name '*usb*'

…and for each symbolic link, rm it; for each hard file, you could temporarily disable it with “bzip2” or “gzip”. Then try reboot again, but be sure you have used “systemctl disable nv-l4t-usb-device-mode.service” first. If the service then continues, see if the service is via systemd:
systemctl status nv-l4t-usb-device-mode.service
…if this service is not running, and device mode still exists, then something else started (and should not have started it outside of systemd).

1 Like

there was a second one running because of the disable has removed it.