How to disable bbox display?

I set display-bbox false by using the following code
g_object_set (G_OBJECT (nvosd), “display-bbox”, FALSE, NULL);
but it still display bbox .
How to disable bbox display?

Can you share your environment (Jetson or dGPU) and exact version?

Use deepstream_test1 as an example, adding the setting as you list and recompile the code and it can disable bbox display correctly.

  nvosd = gst_element_factory_make ("nvdsosd", "nv-onscreendisplay");
  g_object_set (G_OBJECT (nvosd), "display-bbox", FALSE, NULL);

dGpu deepstream5.0 by using docker image (nvcr.io/nvidia/deepstream:5.0-dp-20.04-triton)
nvosd = gst_element_factory_make (“nvdsosd”, “nv-onscreendisplay”);
g_object_set (G_OBJECT (nvosd), “display-bbox”, FALSE, NULL);
can not disable bbox display

Can you upgrade your docker image to version 6.1.1 and check behavior again?