How to disable console on HDMI

sudo systemctl set-default into the console mode and it work well.
And then I want to disable the console on HDMI, so # CONFIG_FRAMEBUFFER_CONSOLE=y and make the Image again. But it does not works. It’s JP 4.6.3.
Here is the log

[   65.013136] nvdec 15480000.nvdec: fw name:nvhost_nvdec030_ns.fw
[   65.272281] tegradc 15200000.nvdisplay: blank - powerdown
[   65.314687] extcon-disp-state external-connection:disp-state: cable 47 state 0
[   65.314689] Extcon AUX1(HDMI) disable
[   65.335948] tegra_nvdisp_handle_pd_disable: Powergated Head1 pd
[   65.336243] tegra_nvdisp_handle_pd_disable: Powergated Head0 pd
[   65.336387] tegradc 15200000.nvdisplay: unblank
[   65.336859] tegra_nvdisp_handle_pd_enable: Unpowergated Head0 pd
[   65.336925] tegra_nvdisp_handle_pd_enable: Unpowergated Head1 pd
[   65.337853] Parent Clock set for DC plld2
[   65.344920] tegradc 15200000.nvdisplay: hdmi: tmds rate:594000K prod-setting:prod_c_hdmi_300m_600m
[   65.346241] tegradc 15200000.nvdisplay: hdmi: get YCC quant from EDID.
[   65.415934] extcon-disp-state external-connection:disp-state: cable 47 state 1

For demo08
If CONFIG_FRAMEBUFFER_CONSOLE=y very thing works well
if #CONFIG_FRAMEBUFFER_CONSOLE=y there are serval cases
1.sudo ./video_dec_drm --disable-video -wx 0 -wy 0 it does not work.
2.sudo ./video_dec_drm test.h264 H264 --disable-ui -wx 0 -wy 0 can show the video but the picture is in the center not start at (0,0) and not full of the screen.
3.I flow the step 2, sudo ./video_dec_drm test.h264 H264 -wx 0 -wy 0 the ui can be showed but the picture and UI are in the center not start at (0,0) and not full of the screen

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

I write echo 0 > /sys/class/graphics/fb0/blank

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.