How to disable debug UART completely on AGX Orin

Hello forks,

We are trying to use the 5x UART interface of AGX Orin as COM ports. With debug UART enabled, we have noticed that:

  • UART C (serial@c280000) is linked to /dev/ttyTCU0
  • UART E (serial@3140000) is linked to /dev/ttyAMA0

We tried to remove the “console” related arguments under /boot/extlinux/extlinux.conf, which becomes

      APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 mminit_loglevel=8 firmware_class.path=/etc/firmware fbcon=map:0 net.ifnames=0

But we still get the following information in the boot-up process

**  WARNING: Test Key is used.  **
L4TLauncher: Attempting GRUB Boot
L4TLauncher: Attempting Direct Boot
EFI stub: Booting Linux Kernel...
EFI stub: Using DTB from configuration table
EFI stub: Loaded initrd from LINUX_EFI_INITRD_MEDIA_GUID device path
EFI stub: Exiting boot services and installing virtual address map...

We are grateful if you would share any related experience or feedback.


We also found that, after removing the console arguments of the extlinux.conf, UART C will be linked to /dev/ttyTHS2.

However, when we try to send characters from /dev/ttyTHS2 via minicom, the receiver needs to press an additional “new line” to receive the characters . On the other hand, AGX Orin is not able to receive any character from another computer.

hello kaichu.wu,

there’re only UART1/2/5 were used as UART ports on DevKit.
in addition, Orin series is same as Xavier series that using combine UART.

we have not verify the use-case by disabling that. we cannot guarantee the real use-case for transferring data as it’s not in our supported use cases/features, there is no suggestion currently.

Thanks for your quick response. We will try to figure out a solution for our usage.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.