How to disable ECC check (2)

Continuing the discussion from How to disable ECC check:

hi ShaneCCC,

I was trying to fix hardware issue, and sorry for the late response on the last topic.

I have tried your suggestion
“sudo ./flash.sh -r -k rce-fw jetson-xavier-nx-devkit mmcblk0p1”, but I got error message as below:

… …
[ 0.8849 ]
[ 0.9027 ] Signed file: /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader/temp_user_dir/boot_sigheader.img.encrypt
l4t_sign_image.sh: Generate header for boot_sigheader.img.encrypt
l4t_sign_image.sh: chip 0x19: add 0x27a7800 to offset 0x8 in sig file
l4t_sign_image.sh: Generate 16-byte-size-aligned base file for boot_sigheader.img.encrypt
l4t_sign_image.sh: the signed file is /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader/temp_user_dir/boot_sigheader.img.encrypt
done.
Making recovery ramdisk for recovery image…
Re-generating recovery ramdisk for recovery image…
~/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader/ramdisk_tmp ~/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader ~/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra
30402 blocks
_BASE_KERNEL_VERSION=4.9.201-tegra
cp: cannot stat ‘/home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/rootfs/usr/bin/cut’: No such file or directory
failed command: cp -fv /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/rootfs/usr/bin/cut /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader/ramdisk_tmp//bin/cut

Please help to advise how i can fix the issue.

Thanks,

hal.

Could you try without “-r” like below.

sudo ./flash.sh -k rce-fw jetson-xavier-nx-devkit mmcblk0p1

hi ShaneCCC,

I treid the command without -r, but still same error message:
cp: cannot stat ‘/home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/rootfs/usr/bin/cut’: No such file or directory
failed command: cp -fv /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/rootfs/usr/bin/cut /home/hwang/nvidia/L4T_32.5.1/xavier/Linux_for_Tegra/bootloader/ramdisk_tmp//bin/cut

please help to have a look.

Thanks,

hal.

hi ShaneCCC,

I rebuild a new development system, and apply patch you mentioned in previous ticket

Apply below patch and update the RTC firmware by replace the …/Linux_for_Tegra/bootloader/camera-rtcpu-rce.img and update it by below command

sudo ./flash.sh -r -k rce-fw jetson-xavier-xxxx mmcblk0p1

0001-media-camera-csi-disable-ECC-CRC-check.patch.txt (2.6 KB)
camera-rtcpu-rce.img (263.0 KB)

I can flash the dev kit without error this time, but I still get the same error in trace log as before.
Attached log file.

I am wondering what this error means:
“kworker/0:3-1743 [000] … 132.140711: rtcpu_nvcsi_intr: tstamp:4545429990 class:CORRECTABLE_ERR type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004”

and how I can fix errors like

kworker/0:3-1743 [000] … 132.140711: rtcpu_nvcsi_intr: tstamp:4545429990 class:CORRECTABLE_ERR type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004

 kworker/0:3-1743  [000] ....   132.140711: rtcpu_nvcsi_intr: tstamp:4545431253 class:GLOBAL type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004

 kworker/0:3-1743  [000] ....   132.140711: rtcpu_nvcsi_intr: tstamp:4545431253 class:CORRECTABLE_ERR type:STREAM_VC phy:0 cil:0 st:0 vc:0 status:0x00000004

 kworker/0:3-1743  [000] ....   132.140714: rtcpu_vinotify_error: tstamp:4545438014 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:4545432935 data:0x00400060

 kworker/0:3-1743  [000] ....   132.140721: rtcpu_vinotify_event: tstamp:4545443273 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:4545432935 data:0x00400060

 kworker/0:3-1743  [000] ....   132.140722: rtcpu_vinotify_event: tstamp:4545443434 tag:CHANSEL_SHORT_FRAME channel:0x01 frame:1 vi_tstamp:4545432935 data:0x01000000

 kworker/0:3-1743  [000] ....   132.140723: rtcpu_vinotify_event: tstamp:4545443596 tag:RESERVED_19 channel:0x23 frame:1 vi_tstamp:3719954208 data:0x01020001

 kworker/0:3-1743  [000] ....   132.140724: rtcpu_vinotify_event: tstamp:4545443736 tag:ATOMP_FE channel:0x00 frame:1 vi_tstamp:4545432937 data:0x00000000

 kworker/0:3-1743  [000] ....   132.140725: rtcpu_vinotify_event: tstamp:4545443894 tag:RESERVED_19 channel:0x23 frame:0 vi_tstamp:3719983776 data:0x07020002

 kworker/0:3-1743  [000] ....   132.140726: rtcpu_vinotify_event: tstamp:4545444032 tag:RESERVED_18 channel:0x23 frame:0 vi_tstamp:3720195136 data:0x10000000

Your help will be great appreciated.

hal.
trace-20211204-01.log (5.2 MB)

Modify the error_config.stream_intr_mask = 0xFF to try. Also there have tag:CHANSEL_SHORT_FRAME need to check the output size.

hi ShaneCCC,

I have modified error_config.stream_intr_mask = 0xFF in csi5_fops.c, but still same crc error.

for “tag:CHANSEL_SHORT_FRAME” error, what is the most possible problem?

Thanks,

hal.

The CHANSEL_SHORT_FRAME tell the output size less than expected.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.