How to disable ECC check


I am developing my own camera module and have some problems.
In the trace log, I found error message as below:
“kworker/0:0-4 [000] … 223.950617: rtcpu_vinotify_error: tstamp:7412502667 tag:CSIMUX_FRAME channel:0x00 frame:1 vi_tstamp:7412497257 data:0x00400060”
In “Jetson/l4t/Camera BringUp -”, it shows “Can try disable the ECC check by modify the REG INTR_STATUS/ERR_INTR_MASK/ERROR_STATUS2VI_MASK to try it” to avoid this error.
Please help to advise how to disable the ECC check as mentioned above? Where to set these REG?



trace-20211101A.log (3.5 MB)
Attached trace log.

Apply below patch and update the RTC firmware by replace the …/Linux_for_Tegra/bootloader/camera-rtcpu-rce.img and update it by below command

sudo ./ -r -k rce-fw jetson-xavier-xxxx mmcblk0p1

0001-media-camera-csi-disable-ECC-CRC-check.patch.txt (2.6 KB)
camera-rtcpu-rce.img (263.0 KB)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.