How to disable filesystem init logs (console logs)

Hi All,

We have customized board based on Jetson-TK1.

We are getting proper console logs on UART port when following kernel cmd line passed :
console=ttyS2,115200n8 no_console_suspend=1 consoleblank=1

for disable the console logs , we use below kernel command line:
console=/dev/null,115200n8 no_console_suspend=1 consoleblank=1

then , kernel logs not printed on UART port , but filesystem init logs printed on LCD(fb0).How to disable logs printed on LCD?

So how to disable console logs (not printed on UART prot, also not to print on LCD).

we are also test with “quiet” option , but no effect.

Rahul Shah

Any update?

Never done it, but probably if it is actual logs you don’t like, remove package rsyslog.

More likely a better result with fewer side-effects would be to disable the service. On newer releases this would be:

sudo systemctl stop rsyslog.service
sudo systemctl disable rsyslog.service

…but for a TK1 running Ubuntu 14.04:

sudo service rsyslog stop

Not sure about complete disable with older systems, probably just mv the “/etc/init.d/rsyslog” file to a new name somewhere else. A good way to disable a file temporarily is to run bzip2 on it:

sudo bzip2 /etc/init.d/rsyslog

(then just bunzip2 if you want to revert)

Logging from inside of the kernel is a generic Ubuntu mechanism. Any logging during bootloader stage is a completely different issue.

after changing the console parameter (console=/dev/null)in kernel command line, kernel console logs not printed on fb0(LCD) and not on seial console, but filesystem bootup logs are printed on LCD.

As we have LCD based product , so on bootup after bootup logo , log messages displayed on LCD.Which not looks like good.

So how to achieve the same?

Rahul Shah

What do you see from “cat /proc/cmdline”?