How to disable GPU assisted graphics when using chromium-browser?

To debug performance related issue observed while using chromium-browser under Ubuntu 11.04,
I would like to disable GPU assisted graphics and use only the CPU assisted graphics.
My system: Tegra3 CARMA/CUDA from Seco.
I have seen suggestions to use
% chromium-browser --blacklist-accelerated-compositing --blacklist-webgl
–disable-accelerated-2d-canvas --disable-accelerated-compositing
–disable-accelerated-layers

The impact of the above options on my browser’s performance seems to be very small.
My chromium browser version is 10.0.648.205, built for Ubuntu 11.04.
I am going to run more related tests, but maybe someone had already solved a similar
problem, and could provide some hints?

Thanks, -zenon.

Hello Zenon,

Could you verify what is shown on the “about:gpu” page (type it in the address bar) in chromium?

I suspect that the browser that you are using either doesn’t support hardware acceleration, or wasn’t passed the proper flags to enable the hardware acceleration.

If your chromium browser supports hardware acceleration and is run with all appropriate acceleration flags, you should see something similar to the following in the “about:gpu” page:
Canvas: Hardware accelerated
Compositing: Hardware accelerated on all pages and threaded
3D CSS: Hardware accelerated
CSS Animation: Accelerated and threaded
WebGL: Hardware accelerated
WebGL: multisampling: Hardware accelerated
Flash 3D: Hardware accelerated
Flash Stage 3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Texture Sharing: Hardware accelerated
Video Decode: Hardware accelerated
Video: Hardware accelerated
Panel Fitting: Unavailable. Hardware acceleration disabled.

Thanks,
Linux for Tegra
NVIDIA Corporation
2701 San Tomas Expr
Santa Clara, CA 95055

Hi Pedro,

The “chromium-browser” response to the “about:gpu” is quite different from the text which you
suggested should be displayed.
What I have obtained, was the following:

GPU Info

Chrome Version
Data exported Tue May 07 2013 12:09:01 GMT-0700 (PDT)
Chrome version 10.0.648.205 (Developer Build 81283) Ubuntu 11.04
Driver Information
Initialization time 431
Vendor Id 0x10de
Device Id 0x0dfa
Driver vendor NVIDIA
Driver version 302.26
Pixel shader version 4.20
Vertex shader version 4.20
GL version 4.2
GL_VENDOR NVIDIA Corporation
GL_RENDERER Quadro 1000M/PCIe
GL_Version 4.2.0 NVIDIA 302.26
Diagnostics
None

Maybe the about messages have something to do with the message observed while booting:
“Compute mode is already set to PROHIBITED for GPU 0000:01:00.0.”

Experimenting with turning the GPU ON/OFF some time ago I have run the command:
“nvidia-smi -c 2” some time ago.

But using the “nvidia-smi -c 0” (returning to the DEFAULT state) does not make any
difference for the “about:gpu” output.

So, my problem remains:
How to turn the GPU assisted graphics OFF and ON again?

   -zenon