How to disable Gst report messages in terminal window

• Jetson Nano B01
• DeepStream 5.1
• JetPack Version 4.5
• TensorRT Version 7.1.3
• Question type
• Requirement details: Disable report this type of messages in terminal

Report message when running, for example, deepstream_test2 (Python):

Warning: gst-core-error-quark: A lot of buffers are being dropped. (13): gstbasesink.c(2902): gst_base_sink_is_too_late (): /GstPipeline:pipeline0/GstEglGlesSink:nvvideo-renderer:
There may be a timestamping problem, or this computer is too slow.
Warning: gst-core-error-quark: A lot of buffers are being dropped. (13): gstbasesink.c(2902): gst_base_sink_is_too_late (): /GstPipeline:pipeline0/GstEglGlesSink:nvvideo-renderer:
There may be a timestamping problem, or this computer is too slow.

This message is to tell you there is frame dropping due to performance. It will do no harm. Why do you want to disable such log?

Hi @Fiona.Chen,

I am reporting log messages while my code runs. When I enable it with display in a window, I receive around of 5 of these Warning messages in the middle of my log messages.

I would like to remove these warning messages because keeps difficult to read in the log messages in real time.

Maybe you can try to “export GST_DEBUG=0” before run the application.

Hi, sorry for delay.

I’m programming in python, so I this line is just enable for C language.

I read this and I cant find any information using python.

What could I do? I would like to remove debug or enable to save it in a logger file, ensuring that this debug will not be prnted in terminal window.