How to disable HDMI sound and deep color option

Hi

During the bring up process we encounter issues to to make work the hdmi interface with our screen which has DVI interface.

We suspect that the sound and deep color options are enabled which cause to issues with presenting the data over the screen.

We tried the common methods using Xrandr without any success.

How can we check if those options are active and if it is active how it can be disable it?

By default tegra HDMI does not enable deep color…

I think you should share the dmesg instead but not disabling those function.

Also, we don’t guarantee DVI could work fine.

Hi,
Please see dmsg and startx log.
From further reading we understand that there is also Data Island at hdmi protocol which might cause to our problems.
Do you have any idea if this cause to our problem and if yes how can we remove it?

In addition to that where at device tree the default configuration when edid cannot be found is located in order to add configuration of 1024x768 .

Yehonatan.

startXlog (1.2 KB)
dmsg.log (61.7 KB)

Hi,

It has nothing to do with hdmi sound or deep color. Just i2c not able to read the edid. Not sure if this is due to the DVI. Can you try a native HDMI monitor?

[ 48.401846] tegradc 15200000.nvdisplay: hdmi: tmds rate:74250K prod-setting:prod_c_hdmi_54m_111m
[ 48.403254] tegradc 15200000.nvdisplay: hdmi: get YCC quant from EDID.
[ 48.406795] tegra-i2c 31c0000.i2c: no acknowledge from address 0x50

Hi,

The edid reading is not working because our screen (TFT ) does not have I2C interface.
In order to replicate the issue we disconnected the I2C over EVB and connect it to external monitor looks working even though that there is an reading edid error.

From my understanding there is default configuration for cases like this when there is no edid.
At none embeded system I am able to add new configuration at xrandr bu over xavier I failed to do so.
From some searching I read that new screen configuration should be added at device tree.
This is looks logical because when we emulated the error over evb there was default configuration of 640X480 and 1280X720 without ant edid.
Do you know which files should I edit at device tree in order to set my screen configuration which maybe will make it works?

https://elinux.org/Jetson_TX2/r28_Display_debug

After following how to change edid as provided from link we got illegal edid message
The edid is written for DVI.
How can we modify the xavier to support DVI edid or change the edid to comply with Nvidia Xavier?

dviEdid (385 Bytes)

You already have the all source code. Why not check the code?

As my first comment, we don’t support DVI. If you want it to work, you can directly modify the kernel code and let the driver able to read your edid format.

Hi

Can you please help me and provide the file name at kernel which I have to edit in order to from hdmi to dvi ?

edid.c. under nvidia/drivers/video/dc

Art eded.c we change the default_720p_edid to our edid and change use_fallback = true;
while after those modifications we got the error

Yes, so read the code and error log and see why it gives you error.

1 Like

Thank’s
So where can we check the edid error log?

The dmesg.