How to disable on-board RTC?


I have questions about disabling on-board RTC.

Our career board uses an external RTC, so I want to disable the on-board RTC.
I configured driver and devicetree of the external RTC and it works fine.

For disabling, I changed below:

  • Leave VDD_RTC pin unconnected
  • Add a /delete-property/rtc0; under aliases node in devicetree (rtc0 is the on-board RTC)
  • Comment out CONFIG_RTC_DRV_MAX77686 in tegra18_defconfig
  • Set CONFIG_RTC_BACKUP_HCTOSYS_DEVICE=“rtc2” (rtc2 is the external RTC)

The questions are:

  1. Is there anything else I need to do for disabling the on-board RTC?
  2. Can I cut off the power of the on-board RTC for power saving?


Hi, regarding item 2, please keep it, basically do not change any power setting of module.