How to disable RTC0

Hi everyone.
My module is TX2i, it seems to have two RTC, a tegra RTC (/dev/rtc1) and a max77686 RTC (/dev/rtc0).
I’m using rtc1 with external battery, I want to disable the max77686 RTC so that it will not appear in the /dev directory.
I checked the device-tree and found rtc0 in node bpmp_i2c/spmic@3c, but didn’t find a way to disable it.
I also commented out CONFIG_RTC_DRV_MAX77686 before build the kernel, which didn’t work.
Is there a way to disable max77686 RTC completely?

Hi,

It should work by disabling this config. So yo still see rtc0 and rtc1 present after disabling it?

And please share your release version. The latest release is Jetpack 4.6.4. It would be great if you can use the version.

Thanks for your reply.
It was my mistake, CONFIG_RTC_DRV_MAX77686 wasn’t completely diabled, now it works, only rtc1in /dev/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.