How to disable Shell outputs on HDMI in Text mode

Hi ,

I have a Jetson nano board running Linux in Text mode, the board is connected to monitor by HDMI port.

when booting-time the monitor shows logs. My application is draw pictures by DRM driver.

How can I disable these kernel/systemd/ other logs? Thanks.

Remove tty0 in your kernel commandline.


I remove the “console=tty” from the file ‘/boot/extlinux/extlinux.conf’. after reboot device, the outputs still print to the hdmi monitor.

please check your dmesg and see if it is really getting removed.

[ 0.000000] Kernel command line: tegraid= ddr_die=2048M@2048M section=256M memtype=0 vpr_resize usb_port_owner_info=0 lane_owner_info=0 emc_max_dvfs=0 touch_id=0@63 video=tegrafb no_console_suspend=1 console=ttyS0,115200n8 debug_uartport=lsport,4 earlyprintk=uart8250-32bit,0x70006000 maxcpus=4 usbcore.old_scheme_first=1 core_edp_mv=1125 core_edp_ma=4000 gpt tegra_fbmem=0x800000@0x92ca9000 is_hdmi_initialised=1 earlycon=uart8250,mmio32,0x70006000 root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 quiet root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 fbcon=map:0 net.ifnames=0

It is still there.

How can I remove this words ? recompile the dtb?

Check your flash board config. There are something from board config too.

Could you give me some detailed steps to do ?

from the console, I got these information:

cat /proc/device-tree/nvidia,dtsfilename

How did you flash your board?

I downloaded the iso from official server. then flashed into sd card.

I also rebuild the kernel/modules and boot up the new image.

So you didn’t know and never try sdkmanager or the real way to flash the board before?

I just modified the kernel source and replace the image/drivers, then write some applications. but it encounters some problem now.
I do not know how to flash by sdkmanager.

Learn the real development way here. Otherwise there are lots of thing you cannot configure.

Hi WayneWWW,

Thanks, according to the link, It works.
But another problem is that after booting up,the monitor still show login information
Is there any method to disable system’s output through hdmi?

could you share what is the exact “login info” you want to disable?

A screenshot for it?

Ubuntu 18.04.4 LTS my-desktop tty1
my-desktop login:

I want to disable any output through hdmi, until my app draw pixels by DRM driver.

I am not sure if you can disable fbcon in kernel defconfig. Please try.

There is a tegra_defocnfig in your kernel source and should be one setting for FBCON, disable it and console won’t work anymore.

Hi WayneWWW,

I removed config_framebuff_console and config_log from the kernel config then reboot,
the monitor always show nvidia logo, how can I disable it in bootloader?

There is no such “config_log” in our config. What did you revmoe?