how to disable USB 3.0 LPM

Problem: I have a USB 3.0 device (Pointgrey Chameleon3 camera) that is getting its USB 3.0 LPM levels U1 and U2 enabled (and this is interfering with proper operation). Perhaps this is a bug in the kernel, because this happens with R23.2.0 but not with R24.2.1. It also only happens (with R23.2.0) when I have the camera connected directly to the TX1, but not when connected via an (unpowered) hub.

Plenty out there on disabling autosuspend (which doesn’t help), but I’m having difficulty finding information on how to disable LPM.

Hi zqpm, as it is not seen on r24.2.1, aren’t you able to upgrade to r24.2.1?

Yes. It’s created a bit of a headache with some of the software we’re using, but that’s the solution we settled on.

Hi zqpm,
We strongly suggest you migrate to the latest r24.2.1.

However, if you inevitably have to stay on r23.2, probably you can try to port the FW and source code of xhci driver from r24.2.1 to r23.2:
FW path:
xhci driver: