How to drop frames when the pipeline gets slow?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) GPU
• DeepStream Version 6.2*
• Issue Type( questions, new requirements, bugs) questions

Due to some computational issues at the probe, the pipeline has become sluggish and eventually terminates. I am actively working on reducing the complexity at the probe to improve performance. However, I am also interested in learning how to discard frames when the pipeline experiences slowdowns. I have attempted to address this by adding a queue with the property leaky set to 2, but it appears that this solution is not effective. Could someone please suggest a solution to this problem?

Hi @daredeviles888

You also need to set the max size, otherwise the queue won’t drop any buffers. Try placing the queue before the element that is causing the bottleneck.

queue leaky=2 max-size-buffers=1

Another option is limiting the DeepStream processing interval using the interval property on nvinfer.

1 Like

It should work if the “queue” is set correctly in proper place.

You can also add “videorate” to slow down the stream before the probe.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.