How to edit Nvidia sample material on my object?

I have applied metal material from excellent Omniverse material library. How can edit it on my material now?
I need to make a tint to it, it is a bright blue metal…

Pekka

Laying down Materials in Machinima is much more better experience that making the same in Unreal Editor. great!
I found out a nice blue metal material:

But how can I edit it to make it not so black on corners, angled reflections you see?

I am looking for this kind of metal:

@pekka.varis Can you post a screenshot like the one above of your asset, but using RTX path-traced rendering instead? I’m curious if you still get those black corner shapes in PT mode. That might help us diagnose the issue.

Johnny - you are right! With Path-traced rendering the metal looks perfect :D

However I have already pointed out problems with path-traced renderings with Machinima so they are not right now in my toolset:

I rendered short animation with RTX path-traced:

Here is the same animation rendered in RTX real-time:

Ok, I got it :)
You just have to find a correct shader under the “looks” folder of your root, and there you can adjust all parameters. I was just confused by all these folders…

1 Like

Let me try some tests myself and get back with you.

@pekka.varis For your stage with this asset using RTX real-time rendering, try enabling Sampled Direct Lighting and/or more reflection bounces in the Real-Time Ray Tracing render settings. Depending on what you’re wanting, you may not need both. I tried this with a test asset similar to yours and it helped a lot. Let me know if this works for you.

Screenshot 2021-06-04 163547

This is so great :)
Sampled Direct Lighting ON and Raising max reflection Bounces to 3 solved this “dark metal reflection” issue.
Here is a short render:

This is made with native Omniverse metal, that I tweaked to my liking.

The result is qood enough for my need for now. Path-traced renderings are still too noisy and slow to render. I hope that new Iray Photoreal renderer would be some solution…

I made a 3000 pix wide rendering and scaled it down in premiere:

It helps a bit in the flickering of the small holes at the back wall of the cabin…
But not much. I think I have to put some dark plane right behind the holes.

1 Like

The black plane behind the holes made a huge difference, now the true design of this cabin comes through :) customers gonna love it.

Rendering took only 5 min, 3000 pi wide and scaled down to Full HD in premiere. Bloom and Simple fog ON, Sampled Direct Lighting ON and Raising max reflection Bounces 3, just the same way as described earlier in this topic.

These RTX Real-time renderings are fine for now, also material assigning and editing them is clear now. I can focus on new content creation now.

1 Like

The render has improved a lot. A solution must be found for these small artifacts in reflections and holes etc…

1 Like

You have some challenging attributes to your object, and I am very impressed Pekka with your ability to discover workarounds to unintended artifacts. This is looking better and better. Can’t wait to see how far you can take this. And can’t wait to help you take it further as well!

1 Like

Hey, I tried to test this metal material with new 2021.1.1 update.

If I have max reflection bounces 3 ( this was the solution to dark edges ) I get some funny renders:

RTX Real-time / antialiasing execution mode: performance
Dome lighting ON


Same thing with antialiasing execution mode: Quality


antialiasing execution mode: Quality
Dome Lighting OFF


So if I want to have antialiasing execution mode: Quality
and Dome lighting ON then my only option was to lower max reflection bounces back to default 1.

So I get those black edges again :P
This is not an issue to me, I can easily make my animations with this specific metal without the dome lighting OFF, I make them inside a warehouse anyway. Jut to let you know these odd render artifacts…