How to enable PCIE_WAKE function on NX Devkit

Hi Nvidia,
We set the NX to suspend mode (execute “systemctl suspend” command), and we try to set the PCIE_WAKE* pin to low to wake up NX, but nothing happens.

According to the NX Pinmux table, the PCIE_WAKE* shows the WAKE Pin is “No”. Does it mean that the wake-up function for this pin is invalid?

And if we want to wake up NX, is there any Pin can we can use?
Thank you.

Hi,

In our internal documents I see it as marked “yes”. Which document are you referring to when you said it is marked as “No”?
Try again with the attached patch. If you still see issue, share completed uart logs and lspci output.

Thanks,
Manikanta0001-Change-PEX_WAKE-pinmux-setting-from-pull_up-to-p.patch.txt (1.6 KB)