How to enable PRIME Synchronization?

Hi, everyone

I am facing screen tearing problem. yesterday i installed nvidia prime successfully according to this article https://devtalk.nvidia.com/default/topic/957814/linux/prime-and-prime-synchronization/. After that i found out that i am having screen tearing problem and tried to enable PRIME Synchronization according to the article. Base on the requirement stated in the article, my laptop can fulfill it. Here is the details:

my laptop`s system is deepin 15.5 that is one of debian sub distribution with linux kernel 4.9.0

X.Org X Server 1.19.3

Nvidia graphic drivers is NVIDIA-384.98 version

I follow the instructions of the article, run ‘sudo rmmod nvidia-drm; sudo modprobe nvidia-drm modeset=1’ to enable DRM-KMS. when i run ‘sudo rmmod nvidia-drm’ the output is “rmmod: ERROR: Module nvidia_drm is in use”; then i run ‘sudo modprobe nvidia-drm modeset=1’ there is no output. next i run ‘sudo cat /sys/module/nvidia_drm/parameters/modeset’ the output is ‘N’ which means nvidia-drm modeset is not enabled.

when i try to run ‘xrandr --output eDP-1-1 --set “PRIME Synchronization” 1’ the screen goes black for a moment. after i run xrandr --verbose|grep PRIME, the output is

PRIME Synchronization: 0
PRIME Synchronization: 1
PRIME Synchronization: 1

which means Prime Synchronization has not been enabled yet. I try to google other solutions, but all of them cannot enbale Prime Synchronization. Now, i really do not know what is wrong and how to enable Prime Synchronization.

I really need your help. please help me, i really appreciate that. since i major in business not IT, please try to put everything in details, so that i can follow it. Thanks in advance.

1 Like

I have the same problem.
Ubuntu 17.10
laptop with nvidia prime (gtx1050 + intel)

I can’t get PRIME SYnchronization to 1

I always get
PRIME Synchronization: 0

1 Like

Solved:

edit /etc/modprobe.d/nvidia-graphics-drivers.conf

change the last line from

options nvidia_387_drm modeset=0

to

options nvidia_387_drm modeset=1

save and exit, then run

sudo update-initramfs -u

reboot
1 Like