How to enable Testing Jetson Nano RTC Battery health

Hi,

I’m looking for a way to enable the output shown in the solution to the linked post. As for now I’m always missing the last 6 lines. How to enable them?

Continuing the discussion from Testing Jetson Nano RTC Battery health:

Do you enable the backup-battery in device tree?

I don’t think I did. Is it well documented in the device tree documentation?

Have reference to the driver …/kernel/kernel-5.10/drivers/mfd/max77620.c for the backup-battery property.

Are you referring to this?

		max77620: max77620@3c {
			maxim,power-shutdown-gpio-states = <1 0>;
			low-battery-monitor {
				maxim,low-battery-shutdown-enable;
			};

It is enabled. It is also part of the system I’m currently running

/sys/firmware/devicetree/base$ ll i2c@7000d000/max77620@3c/low-battery-monitor/
total 0
drwxr-xr-x 2 root root  0 Aug 17 11:38 ./
drwxr-xr-x 9 root root  0 Aug 17 10:51 ../
-r--r--r-- 1 root root  0 Aug 17 11:37 maxim,low-battery-shutdown-enable
-r--r--r-- 1 root root 20 Aug 17 11:34 name

Do I have to enable anything else in the device tree other than what I mentioned ealier?
I did check all ‘of_property_*’ values in the driver you mentioned. The one making most sense would be ‘low-battery-monitor’ which already seems to be enabled.

You need to add backup-battery in device tree and make sure the status is “okay”

			backup-battery {
124 				maxim,backup-battery-charging-current = <100>;
125 				maxim,backup-battery-charging-voltage = <3000000>;
126 				maxim,backup-battery-output-resister = <100>;
127 			};

I gave that a try. Is it to be expected that, without battery, you don’t see any changes in the output mentioned?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.