How to enable TX2 I2S1,JetPack4.6

hi,
I need tx2 audio function,and the audio is good on JetPack4.2.
but below steps can’t work anymore on JetPack4.6.

amixer -c tegrasndt186ref sset "I2S1 Mux" "ADMAIF1"
aplay -D hw:tegrasndt186ref,0 Alarm01.wav

I followed this topic I2S DOUT is not workiing to use config-by-function.py to reconfigure i2s1,

sudo /opt/nvidia/jetson-io/config-by-function.py -o dtb i2s1
sudo reboot

it’s worked but not based on my dtb file,so How to modify my dts to enable this I2S?

thanks.

Hi suchb,

There is an alternate method to recofigure i2s1 (i.e settings its pinmux) mentioned at link. Suggest you to try this as this does not alter your customised DTB that you have flashed.

Above method helps to edit pinmux function in the pinmux table for i2s and generates DT which is further converted to cfg file that needs to be reflashed for the pinmux to take effect.

Thanks

Hi, @atalambedu
thanks for you suggestion.
could you tell me how to use devmem2 to configure i2s1,like below

Enable SPI1(software spi3) Pinumux
sudo devmem2 0x02430038 w 0x401
sudo devmem2 0x02430040 w 0x455
sudo devmem2 0x02430048 w 0x401
sudo devmem2 0x02430050 w 0x409

thanks.

Hi suchb,

Pinmux change via generated cfg is the preferred method. If you prefer to set via devmem2, refer cfg for the register (ex: 0x02430038) ans its value (0x401) you generate with necessary modification for i2s1

Thanks

thanks.