How to enable UART4 of TX2 in Jetpack4.2

Hello all,

The Jetson TX2 OEM Product Design Guide said “(UART4)The default selection for the multiplexers is to the WLAN/BT device.”

I want to Know how to configure UART-TX UART-RX pins as a UART.

And the Guide also said “Available if not used for on-module WLAN /BT (selected by on-module multiplexor)”, is this means if configure as uart, WLAN/BT will not work anymore?

Hi, UART4 is always configured as UART. If not used for on-module WLAN/BT, the bluetooth part will not work since its UART port is disconnected to host chip.

I need to use UART4 as a UART, not for WLAN/BT device , so how to change UART4 from WLAN to a UART?

I think the point is that this is wired such that you cannot do this.

Thank you for reply.
Chapter “12.0 WLAN / BT (INTEGRATED) – JETSON TX2 ONLY” of the official document <<JetsonTX2_Series_OEM_Product_Design_Guide.pdf>> said “The UART interface is multiplexed and either route
these to the WLAN/BT device or to the connector pins for use on the carrier board. The default selection for the multiplexers is to the WLAN/BT device.”;
and In Chapter “13.3 UART”, it said "One of the UARTs is used for the WLAN/BT on Jetson TX2 or as
UART3 at the connector depending on the setting of a multiplexor. ";
so i think UART4 can be configured as a UART , but i don’t know how to do it.

Hi, is it possible to configure UART4 as a UART(not used for WLAN)?
if it’s possible, how to change UART4 from WLAN to a UART?

I don’t know if any route is possible away from bluetooth…maybe, but I don’t know. The bluetooth is something “extra” and not necessarily wired the same as the rest of the UART ports (even if you reprogram this, I don’t know if there is any wiring exposed).

Thank you very mcuh.
i will start a new thread for the topic in few days.

Yes. On the Jetson TX2 UART4 (Tegra name) goes to the internal WiFi/BT part by default. If you want to use the UART4 for something external to the SoM (including as GPIOs) you must switch the internal SoM MUX output. The MUX is controlled by QSPI_IO3/GPIO R.04 (GPIO #460). By default this GPIO will be output HI forcing the MUX internally and the external pins H10, H9, G10, and G9 will all be Hi-Z. If you want to switch the MUX externally, you must set GPIO R.04 (GPIO #460) output LOW. Another option is to change the PADCTL_SPI_QSPI_IO3_0 pinmux (@0x0243b000) to be tristate with a pull-down inside of the processor. Once this is done all four signals will be routed external to the SoM through the MUX instead of to the internal WiFi/BT.