How to execute CUDA Debugging with RTX2080Ti.

I would like to use CUDA Debugger with RTX2080Ti.
When I start Regacy CUDA Debug, Nsight Debugger pops up “A CUDA context was created on a GPU that is not supported by the legacy CUDA debugger. Breakpoint will be disabled. See output window for details” message.

RTX2080Ti is base on Turing, but because it cannot use TCC mode.
So I can’t NextGen CUDA Debgger.

How can we use CUDA Debugger ?

You should be able to use the Next-Gen Debugger with a Turing on win10 RS4 or later and display driver 411.63 or later.

See the “Supported Compute Debugger Configurations” on https://developer.nvidia.com/nsight-visual-studio-edition-supported-gpus-full-list for a chart showing the Debugger requirements for GPU, OS, and driver configurations.

Note that TCC mode is not restricted for Turing cards, per se. GeForce cards cannot be put into TCC mode. Only Quadro and Tesla SKUs support TCC mode. Only Quadro cards support both TCC and WDDM modes.

Thank you for the reply.

My environment are as follows.

  • Windows10 Pro 1709(RS3)
  • Driver Version 416.34
  • Visual Studio 2015 Pro
  • Nisight 6.0
  • Using Project CUDA Sample matrixMul

I cannot start Next-Gen Debugger due to the attached dialog.
According to https://developer.nvidia.com/nsight-visual-studio-edition-supported-gpus-full-list, win10 RS3 is supported, too. Is RS4 necessary ?

error_msg_when_nextgen_debug.PNG

error_msg_when_nextgen_debug.PNG

Yes, RS4 or later is required for WDDM mode driver support.
We’ve updated the website accordingly.

Thank you for the information.
I’ve updated Windows to RS4. and the 1st error dialog has been solved.
Although the 2nd error dialog are still displayed, it may be my characteristic problem.
I’ll try something to solve it.

If you don’t have any luck, please translate that 2nd dialog for me. I tried a couple OCR to Japaneese, then translate to English tools, but they all spit out gibberish (I think a higher resolution image would also help).

Thank you for the trying OCR and Sorry for the Japanese.
The Error message is
“Cannot attach Nsight Debugger to the process ‘matrixMul.exe’ on the computer xxx. The operation is not supported. Unknown Error : 0x80004005”.
I continue to try to solve the problem. Thanks a lot.

I am having the same problem on RTX 2070

My environment are as follows.

  • Windows10 Pro 1803(RS4)
  • Driver Version 417.01
  • Visual Studio 2015 Pro
  • Nisight 6.0
  • Using Project CUDA Sample matrixMul

We can’t currently reproduce this problem, but suspect it may be a firewall interfering with our TCP/IP communication between the debugger and the target app. Opening port range 4500-4510 in the firewall may fix this.
Also note that 4500-4510 is not currently configurable to another set of port numbers.

For this specific issue, see Forum Post: https://devtalk.nvidia.com/default/topic/1044685/nsight-visual-studio-edition/attaching-nsight-visual-studio-debugger-to-process-failed/