How to finish a jetpack install after the flash succeeds but the subsequent installs fail?

I’ve tried installing jetpack 3.3 on the jetson TX2 using both of these 2 options:
1: Device accessess internet via router/switch
2: Device accessess inteternet via host machine through setting up a new DHCP server.

option 1: Device accessess internet via router/switch
It always gets stuck on
“Determining the IP Address of Target”
There seems to be no way to get it to ask me to manually enter the IP address of the target.
This is true even though both devices are connect to the same network via wired connections.
And both can ping each other successfully.
I am just not given the option to manually enter the IP address.

option 2: Device accessess inteternet via host machine through setting up a new DHCP server.
This option seems to require the host machine to have 2 network interface cards.
I don’t have 2 network interface cards.
But given that option 1 does not work, I tried it anyway.
I did get this prompt.
“Manually Enter the IP address”
However, when I chose this option, it did not present me with the screen where I could enter the IP address.
Instead it presented me with an “installation done” screen.

This is very concerning because it is my understanding that several packages were not installed because of the failure to obtain the IP address. This means that the installation is NOT done.

I would like to know:

1: precisely what edits were not made because of the the inability to connect with the IP address and how can I make these changes? I want to make sure that I have precisely the correct version of each package to install.

I especially want to make sure that I get the correct versions of CUDA and cuDNN to work with tensorflow 1.11 because this wheel was designed to work with jetpack 3.3:
https://devtalk.nvidia.com/default/topic/1031300/jetson-tx2/tensorflow-1-10-wheel-with-jetpack-3-3/

2: what can I do to force the installation program to ask me for an ip address and then to actually use the ip address to complete the installation fully?

3: Is there a reason why we are being forced through this painful flashing process instead of being able to simply burn an image to a card like we do with raspberry pi?

jetpack allows to select post installation elements and process them without flasing Jetson

If I could continue the process after the initial flashing to install the packages, that would be fantastic.
What is the procedure for doing this?

Run JetPack again, but this time de-select the flashing of the L4T BSP (along with the host-side stuff). Only select the post-flashing components that you wish to install on the target device (like the target-side CUDA toolkit, cuDNN, TensorRT, VisionWorks, ect.)

Then JetPack will prompt you right away for the target device IP, without asking first about the router configuration. Boot your Jetson up first and determine it’s IP with ifconfig, and then make sure you can ping your Jetson from your host PC. Then type that IP into the JetPack GUI and proceed.

I have same issue. How can I get to this? When I run JetPack again everything is the same I cannot deselect anything, I need to select all options (cuda, visionworks,…) otherwise the “next” button won’t get activate.