How to fix Power Supply on J41 Expansion Header

Hi, I have a Jetson Nano and I want to power it from the J41 connector (expansion header) using a 5V/5A power supply (laboratory power supply). The connections are correct, in fact I can turn on and work with the Jetson without problems, but if I turn off the power supply and turn it back on after a few seconds, the Jetson does not turn on anymore (in fact, the power supply tells me that the load is less than 100mA). If I turn off the power supply and turn it back on after 10-15 minutes, the Jetson works perfectly. I have tried with other power supplies and I get the same result. However, if I try to power the Jetson from the Micro-USB port, the Jetson turns on and off without problems.
PS: Jumper J48 is open, not shorted. The board was powered without modifying jumpers or anything, I just connected the 5V and GND pins to the power supply.


PS2: if i disable the auto-on with a jumper on “AUTO ON” (J40), and i turn on the jetson with a button, the jetson work perfectly! so, if i turn off the power supply i’m not forced to wait 10-15 minutes to turn it on another time.

Hi, it seems that your power supply to J41 is not turn off completely. It may has some capacitors inside that can cause this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.