How to Flash Auvidea J120+TX1+Toshiba adapter+Toshiba camera module

Dear community,
Please help me

My setup:
Auvidea J120
Jetson TX1
Auvidea Toshiba adapter
Toshiba camera module 41,3 Mp

Auvidea support send me “manual”

"1. Flash system with JetPack 3.0 + cuda

  1. Copy kernel_24.2.1_galileo_all_included_bin_vx.x.x.tar.gz to TX1 module

  2. Extract files
    tar -zxvf kernel_24.2.1_galileo_all_included_bin_vx.x.x.tar.gz

  3. Go into the extracted file
    cd kernel_24.2.1_galileo_all_included

  4. Copy boot, modules file to system boot:
    sudo cp -rf /boot/* /boot/.
    sudo cp -rf /boot/dtb/* /boot/.
    sudo cp -rf /modules/lib/* /lib/.
    // -rf forces an overwrite of an existing file, and copies directories recursively

  5. sudo reboot

  6. Make sure that Galileo2 stands in /etc/modules over nvhost_vi
    sudo gedit /etc/modules
    7.1 enter galileo2 over nvhost_vi save file and close it

  7. Load galileo 2 and initialize it:
    sudo modprobe galileo2 // if this does not work make sure that galileo2.ko is in /lib/modules/3.10.96-tegra/kernel/drivers/media/i2c/.
    sudo depmod //this will make sure that galileo2 is automatically loaded on start up

  8. Reboot to apply changes and you should see now in the devices file 6 video devices:
    ls -s /dev/video*
    video0, video1, video2, video3, video4, video5
    // on J120 the camera module should be recognized as video0 or video4, but all six devices should show up

You can now execute the following gstreamer command to get the video of the inputs:

1080p60: gst-launch-1.0 v4l2src device=/dev/video0 ! ‘video/x-raw, width=1920, height=1080, framerate=60/1, format=UYVY’ ! nvvidconv ! ‘video/x-raw(memory:NVMM), width=1920, height=1080, framerate=60/1, format=I420’ ! nvoverlaysink sync=false "

Ok,
I flashed module from Jetpack 3.0 BSP firmware Auvidea 2.1
After that I tried to copy files
I discovered that in my modules I have 3.10.96+ and 3.10.96-tegra, system boot 3.10.96+

modprobe not found galileo2 in 3.10.96+
I tried copy galileo2.ko to 3.10.96+

ls -s /dev/video*
0 /dev/video4

gst-launch, nvgstcapture not results…

Hi s.udovkin,

I can’t help much on this issue due to I don’t have the board, also don’t know what Toshiba adapter+Toshiba camera module is.
Could you try other USB camera to confirm the TX1+AuvideaJ120 work well first?
Have you contacted with Auvidea to know if they can provide support?

Hi kayccc,

Toshiba module : https://auvidea.eu/product/70604/
Toshiba camera module : https://auvidea.eu/product/43203/

Yes, I wrote to Auvidea support…only this manual sent to me…

I also can’t give help on someone else’s carrier board, but I see the manual wants flash with JetPack3.0, and this installs L4T R24.1. This is extremely old and only 32-bit user space. Hardly anything worked well there since it was the very first port when only the kernel was 64-bit and everything else was migrating to 64-bit from 32-bit user space.

You will want to find out if something newer is available for their “board support package” (“BSP”) which can be applied to any of the newer JetPack/L4T releases.

Unfortunately, Auvidea stop supporting camera and last update BSP JetPack3.3 without camera drivers…

JetPack3.3 would be far better than JetPack3.0. If you are saying the release with JetPack3.3 compatibility did not offer the camera driver, then you are probably out of luck unless you can port the driver.