How to flash image to Orin NX with Orin Nano carrier board

Dear Nvidia support,
I am trying to flash the standard JetPack 5.1.3 image to a 16GB Orin NX attached to an Orin Nano devkit board. The NX, a model P3767, does not have SD card. The carrier board (model P3766) has NVME slots, but no NVME memory is attached.
The JetPack is downloaded and installed with the latest SDK manager.
Host runs Ubuntu 20.04.

  1. flash with the sdkmanager: failed with storage undetected. I tried the storage type selection SD, NVME, and custom/autoconf.
  2. Command line: I tried both
    # sudo ./flash.sh jetson-orin-nano-devkit internal
    # sudo ./flash.sh jetson-orin-nano-devkit mmcblk0p1
    all hang at “tegrarcm_v2 --chip 0x23 0 --oem platformdetails storage storage_info.bin”

Please advise how can I flash the image in my situation.
Thanks.

Looks like the Orin NX does not have internal storage:

Please correct me if I am wrong.

I attached a NVME storage and flash with sdkmanager, succeeded. Login the NX, I did not see any mmc device.

I believe your understanding is correct. The method you described in your fix is the same way I flash my Orin NX unit.

@noah.g Thanks for the input.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.