How to handle signals behavior of cuda-gdb through vscode launch configurations

I use cuda-gdb version 11.4 release.
I try to configure cuda-gdb through vs-code launch configurations.
This is the configurations setup I wrote in order to mask SIG44:

"configurations": {
		        "name": "CUDA C++: Launch",
                "type": "cuda-gdb",
                "request": "launch",
				"program": "${command:cmake.launchTargetPath}",
				"externalConsole": false,
				"stopAtEntry": false,
				"initCommands": ["cd ${workspaceFolder}"],
				"setupCommands": [
				{
					"description": "ignore SIG44 from Kaya",
					"text": "handle SIG44 noprint nostop",
				}
				],
			},

However, it doesn’t work, SIG44 keeps stopping the cuda-gdb debugger.

I’m surprised Intellisense didn’t give you an error for this. The extension only supports initCommands, the debug adapter doesn’t do anything with setupCommands. Try moving any commands you want passed to cuda-gdb to initCommands. You can also send commands to cuda-gdb during a debug session via -exec or ~, similar to cpptools.

Is there an option to read commands from an init file as in gdb?

Not currently but I can submit that for consideration in a future release.