How to handle the SPI EEPROM as NVMEM?

Hello.
I’m trying to handle the EEPROM (via SPI) as NVMEM.
but the error happens that follows:

spi_master spi0: /spi@7000d400/eep@0 has no valid ‘reg’ property (-22)

Please tell me what’s my wrong point. or some advice.
(‘93xx56’ is own device driver compatibles)

spi@7000d400 {
		status = "okay";
		compatible = "nvidia,tegra210-spi";
		reg = <0x0 0x7000d400 0x0 0x200>;
    	spi-max-frequency = <1000000>;
	    nvidia,enable-hw-based-cs;
	    nvidia,cs-setup-clk-count = <0x1e>;
	    nvidia,cs-hold-clk-count = <0x1e>;
	    nvidia,rx-clk-tap-delay = <0x1f>;
	    nvidia,tx-clk-tap-delay = <0x0>;

		maker_eep: eep@0 {
			status = "okay";
	    	spi-max-frequency = <1000000>;
	    	spi-cs-high;
	  		spi-cpha;
	    	compatible = "microchip,eeprom-93xx56";
	    	devnode = "m_eep";
	    	size = <256>;
	    	data-size = <16>;	/* 93LC56B	*/
	    	model_name: mod_name@0 {
	    		reg = <0 16>;
	    	};
	    	cam_serial: cam_no@0 {
	    		reg = <0x10 16>;
	    	};
	    	cam_version: cam_ver@0 {
	    		reg = <0x20 16>;
	    	};
	    	board_serial: bd_no@0 {
	    		reg = <0x30 16>;
	    	};
	    };
	};

thanks.

Try add #address-cells = <0x2>; to it.

Hello, Shane.
I tried your advice, but the error has not solved.

Then I divided the device tree description.

[common.dtsi]
....
spi@7000d400 {
    status = "okay";
    compatible = "nvidia,tegra210-spi";
    reg = <0x0 0x7000d400 0x0 0x200>;
    spi-max-frequency = <1000000>;
    nvidia,enable-hw-based-cs;
    nvidia,cs-setup-clk-count = <0x1e>;
    nvidia,cs-hold-clk-count = <0x1e>;
    nvidia,rx-clk-tap-delay = <0x1f>;
    nvidia,tx-clk-tap-delay = <0x0>;
    };
....

 [eeprom-manager.dtsi]
/ { 
        maker_eep: eep@0 {
        status = "okay";
        spi-max-frequency = <1000000>;
        spi-cs-high;
        spi-cpha;
        compatible = "microchip,eeprom-93xx56";
        devnode = "m_eep";
        size = <256>;
        data-size = <16>;	/* 93LC56B	*/
        model_name: mod_name@0 {
            reg = <0 16>;
        };
        cam_serial: cam_no@0 {
            reg = <0x10 16>;
        };
        cam_version: cam_ver@0 {
            reg = <0x20 16>;
        };
        board_serial: bd_no@0 {
            reg = <0x30 16>;
        };
    };
};

That error disappeared, but the eeprom device is not seem '/dev', ‘/sys/bus/spi/’ folders and so on. ( The driver is in ‘lsmod’ list. )
And ‘/sys/bus/nvmem/devices/’ folder is empty.
Why is it?

Thanks.

I saw the device tree in below link there is no the REG setting like yours.
You may consult with the vendor for the device tree for the 93xx56 driver.

The linked topics is my topics at other site.
I wonder why L4T does not detect my device.

I has given up.