How to increase frame rate in deepstream python app, Jetson Nano

when i ran on the terminal: deepstream-app -c [config.txt], everything works fine and the video runs based on how fast the model infers eg. 30fps video would run at 40fps

i’m trying to replicate this setup in the deepstream_test1.py. i have added the videorate element in the pipeline, the video seems to play accordingly ie. when i set the rate 2x with videorate.set_property(‘rate’, 2), the video seems to run two times faster.

However, the callback probe ‘osd_sink_pad_buffer_probe’ seems to still run at a rate of 30fps. Is this cap set by the pgie element in the pipeline?

Appreciate your help, thanks!

Please provide complete information as applicable to your setup.
• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)
• The pipeline being used

Where the position of the videorate is added ?
Is you add the videorate after osd ?
Can you share you code and configuration file ?

Hi, i was able to achieve what i want by setting the nveglglessink property ‘sync’ to 0

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.