How to install DeepStream SDK on AWS g4ad.xlarge? Edit: Solved. Was the wrong VM :)

I’m having an AWS g4ad.xlarge instance (not setup by me). I was trying to follow these instructions Quickstart Guide — DeepStream documentation 6.4 documentation to install DeepStream SDK there.

It fails while trying to install the NVIDIA drivers with:

What am I doing wrong?

I suppose I was provided with the wrong instance. It should have been a g4dn.xlarge…

if the instance include NVIDIA GPU, please install the corresponding driver. In “Supported Products” part of this link, you can get the supported GPU name.

Good, on the new (now correct g4dn.xlarge) instance I got all these warnings in a row, but in the end it looks like the drivers are installed correctly. I think the warnings are related to the missing desktop X. Can you confirm?

Since I’m not intending to do any desktop related things I hope this is fine.

But now the installation of TensorRT fails…


ubuntu@ip-xx.xx.xx.xx:~$ sudo apt-get install libnvinfer8=8.6.1.6-1+cuda12.0 libnvinfer-plugin8=8.6.1.6-1+cuda12.0 libnvparsers8=8.6.1.6-1+cuda12.0 libnvonnxparsers8=8.6.1.6-1+cuda12.0 libnvinfer-bin=8.6.1.6-1+cuda12.0 libnvinfer-dev=8.6.1.6-1+cuda12.0 libnvinfer-plugin-dev=8.6.1.6-1+cuda12.0 libnvparsers-dev=8.6.1.6-1+cuda12.0 libnvonnxparsers-dev=8.6.1.6-1+cuda12.0 libnvinfer-samples=8.6.1.6-1+cuda12.0 libcudnn8=8.9.4.25-1+cuda12.2 libcudnn8-dev=8.9.4.25-1+cuda12.2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libnvinfer-dev : Depends: libnvinfer-headers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
 libnvinfer-plugin-dev : Depends: libnvinfer-headers-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed
 libnvinfer-samples : Depends: libnvinfer-lean-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
                               libnvinfer-lean-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
                      Depends: libnvinfer-dispatch-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
                               libnvinfer-dispatch-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
                      Depends: libnvinfer-vc-plugin-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed or
                               libnvinfer-vc-plugin-dev-cross-amd64 (= 8.6.1.6-1+cuda12.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
ubuntu@ip-xx.xx.xx.xx:~$

Any suggestions? Instance is Ubuntu 22.04.4 LTS (GNU/Linux 6.5.0-1014-aws x86_64)

My CUDA installation was 12.2, as suggested in the gist Quickstart Guide — DeepStream documentation 6.4 documentation. Seems 12.4 is expected (?)

Seems to be the same as here Deepstream 6.4 TensorRT 8.6.1.6 installation

Strange enough

nvcc -V

Command 'nvcc' not found, but can be installed with:

sudo apt install nvidia-cuda-toolkit

After installation of the toolkit:

$ sudo nvcc -V

nvcc: NVIDIA (R) Cuda compiler driver

Copyright (c) 2005-2021 NVIDIA Corporation

Built on Thu_Nov_18_09:45:30_PST_2021

Cuda compilation tools, release 11.5, V11.5.119

Build cuda_11.5.r11.5/compiler.30672275_0

I swear I was following the instructions to install 12.2. but the step “sudo apt update” had no visible effect…

Looks like I managed to install TensorRT by splitting up the monster install command into separate installs. Then, when a dependency problem arises, solve this first and try again.

It is a recursive-iterative process, but in the end it works

please refer to this topic for issue “libnvinfer-headers-dev (= 8.6.1.6-1+cuda12.0) but 10.0.0.6-1+cuda12.4 is to be installed”.

Yes, thanks. It worked for me with careful, sequential, iterative, recursive installation :))

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.