How to install Jetpack to be used along with e-CAM130_TRICUTX2 cameras?

Hi,

I bought e-CAM130_TRICUTX2 three cameras to use them on my Jetson tx2. However, If I try to install Jetpack3.3 it requires to flash the TX2 losing the drivers provided with the camera. How can I install Jetpack so it can be used with these cameras?

Thanks in advance.

Hi,
You can try below steps to install Latest Jetpack3.3 and camera drivers.

  1. Install Jetpack3.3. This will erase all the emmc contents rootfs, drivers, applications etc.
  2. Kindly follow the upgrade procedure as mentioned in the developer guide to update the kernel, device tree, driver modules, application etc. This will install the kernel, device tree, and modules which is based on L4T28.2.1 and won’t affect the rootfs.

Hi,

Thank you very much. It worked. Now it detects my cameras when running:

$ dmesg | grep “Detected ar1335 sensor”

However, when I try to run a gstreaming pipeline, it always shows the same error:

nvidia@tegra-ubuntu:~$ gst-launch-1.0 nvcamerasrc ! nvoverlaysink

Setting pipeline to PAUSED …
Socket read error. Camera Daemon stopped functioning…
gst_nvcamera_open() failed ret=0
ERROR: Pipeline doesn’t want to pause.
ERROR: from element /GstPipeline:pipeline0/GstNvCameraSrc:nvcamerasrc0: GStreamer error: state change failed and some element failed to post a proper error message with the reason for the failure.
Additional debug info:
gstbasesrc.c(3354): gst_base_src_start (): /GstPipeline:pipeline0/GstNvCameraSrc:nvcamerasrc0:
Failed to start
Setting pipeline to NULL …
Freeing pipeline …

Is it a problem with installation or how to fix this?
Thank you in advance.

Hi,
Good to know you updated the driver with Jetpack 3.3
e-CAM130_TRICUTX2 doesn’t support Argus library/ nvcamerasrc. This camera has internal ISP and output frames in YUV format. Argus library supports only Bayer cameras.
You can test the camera with e-CAMTK1_GUVCview demo application which is provided along the release package. Kindly look into the build and install guide for more details.
You can test the camera using any standard V4L2 application also using Gstreamer command with V4L2src.

Thank you very much for your help.
I will follow your instructions.

Hi,

After trying to capture video from camera using v4l2rsc, it shows only the initial frame of the camera, and it does not change. It happens running, for example, the following command:

$ gst-launch-1.0 v4l2src device="/dev/video0" ! “video/x-raw, width=640, height=480, format=(string)I420” ! xvimagesink -e

My final objective is to access camera video from OpenCV and apply some object detection. Please, kindly advice if you know any more straightforward way to do that.

Hi,
We suggest testing with e-camtk1 GUVCview sample application. And make sure you have installed the camera driver properly. Once Camera is up and streaming, you can refer to GStreamer user guide document from the release package.

Yes, you can use OpenCV with our camera, kindly look into the below article on how to obtain maximum performance from OpenCV.

https://www.e-consystems.com/Articles/Camera/accessing_cameras_in_opencv_with_high_performance.asp