How to install openjfx on the jetson tk1?

Hello, I’m attempting to install The BowlerStudio https://github.com/NeuronRobotics/BowlerStudio/ which requires openjfx and I’m having a nightmare of a time.

I first tried to install it using this guide http://elinux.org/Jetson/JavaFX to no avail. I downloaded the 2 files listed and followed the directions. However whenever I try to install the BowlerStudio I still get an error saying that the jfx package hasn’t been installed. Could this be because of 2 different java versions?

ubuntu@tegra-ubuntu:~ java -version java version "1.8.0_33" Java(TM) SE Runtime Environment (build 1.8.0_33-b05) Java HotSpot(TM) Client VM (build 25.33-b05, mixed mode) ubuntu@tegra-ubuntu:~ javac -version
javac 1.8.0_33

On my laptop which is 64bit ubuntu

ubuntu@blue:~ java -version java version "1.8.0_45" Java(TM) SE Runtime Environment (build 1.8.0_45-b14) Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode) ubuntu@blue:~ javac -version
javac 1.8.0_45

I also seem to be unable to find openjfx when I do apt-cache search openjfx in the jetson.
When I do apt-cache search on my laptop (which is also ubuntu) the openjfx is available. I copy pasted the sources from my laptop to the jetson tk1 and did a sudo apt-get update and it still cannot find it. Is there any way to install it via sudo apt-get install on the jetson?

ubuntu@tegra-ubuntu:~/Downloads$ sudo dpkg -i Ubuntu-BowlerStudio-0.2.29.deb
Selecting previously unselected package bowlerstudio.
(Reading database … 188272 files and directories currently installed.)
Preparing to unpack Ubuntu-BowlerStudio-0.2.29.deb …
Unpacking bowlerstudio (0.2.29-1) …
dpkg: dependency problems prevent configuration of bowlerstudio:
bowlerstudio depends on openjfx; however:
Package openjfx is not installed.
bowlerstudio depends on libjpeg62; however:
Package libjpeg62 is not installed.

dpkg: error processing package bowlerstudio (–install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.54ubuntu1.1) …
Processing triggers for gnome-menus (3.10.1-0ubuntu2) …
Processing triggers for desktop-file-utils (0.22-1ubuntu1) …
Errors were encountered while processing:
bowlerstudio
ubuntu@tegra-ubuntu:~/Downloads$ java -version
openjdk version “1.8.0_45-internal”
OpenJDK Runtime Environment (build 1.8.0_45-internal-b14)
OpenJDK Zero VM (build 25.45-b02, interpreted mode)

Please help