How to install rqt_graph in Isaac ROS Docker Container


I am using the Isaac ROS Docker container on a Ubuntu 22.04, 64bit machine. I setup the container using the steps listed here and running:

cd ~/workspaces/isaac_ros-dev/src/isaac_ros_common && ./scripts/

I would like to run rqt_graph in the docker container, but get an error:

$ source install/setup.bash
$ rqt_graph
bash: rqt_graph: command not found

Running rqt --list-plugins gives:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-admin'

I tried running sudo apt-get update && sudo apt-get install ros-humble-rqt-graph but get this error: E: Unable to locate package ros-humble-rqt-graph.

I have also tried building from source using these instructions, but face this error:

[0.353s] WARNING:colcon.colcon_core.package_selection:Some selected packages are already built in one or more underlay workspaces:
	'image_geometry' is in: /opt/ros/humble/install
	'image_transport' is in: /opt/ros/humble/install
	'camera_calibration_parsers' is in: /opt/ros/humble/install
	'message_filters' is in: /opt/ros/humble/install
	'camera_info_manager' is in: /opt/ros/humble/install
	'cv_bridge' is in: /opt/ros/humble/install
If a package in a merged underlay workspace is overridden and it installs headers, then all packages in the overlay must sort their include directories by workspace order. Failure to do so may result in build failures or undefined behavior at run time.
If the overridden package is used by another package in any underlay, then the overriding package in the overlay must be API and ABI compatible or undefined behavior at run time may occur.

If you understand the risks and want to override a package anyways, add the following to the command line:
	--allow-overriding camera_calibration_parsers camera_info_manager cv_bridge image_geometry image_transport message_filters

This may be promoted to an error in a future release of colcon-override-check.
Starting >>> python_qt_binding
Starting >>> cv_bridge
Starting >>> message_filters
Starting >>> camera_calibration_parsers
Starting >>> image_geometry
Finished <<< python_qt_binding [2.71s]                                                                                           
Starting >>> qt_gui
Starting >>> qt_gui_py_common
Starting >>> qt_dotgraph
Finished <<< qt_gui_py_common [2.61s]                                                                                                          
Finished <<< qt_gui [2.65s]
Starting >>> rqt_gui
Starting >>> rqt_py_common
Starting >>> qt_gui_cpp
Starting >>> qt_gui_app
Finished <<< qt_dotgraph [3.26s]                                                                      
Finished <<< rqt_gui [1.62s]                                                                          
Starting >>> rqt_gui_py
Finished <<< image_geometry [7.61s]                                                                   
--- stderr: qt_gui_cpp                                                                                
CMake Error at src/qt_gui_cpp/CMakeLists.txt:2 (find_package):
  find_package called with invalid argument "."

CMake Error at /workspaces/isaac_ros-dev/test/install/python_qt_binding/share/python_qt_binding/cmake/shiboken_helper.cmake:15 (message):
  Unknown Python version:
Call Stack (most recent call first):
  src/qt_gui_cpp_shiboken/CMakeLists.txt:41 (include)

Failed   <<< qt_gui_cpp [2.90s, exited with code 1]
Aborted  <<< qt_gui_app [2.97s]                                                                                  
Aborted  <<< camera_calibration_parsers [8.45s]                                                                  
Aborted  <<< rqt_gui_py [1.83s]                                                                                                               
Aborted  <<< rqt_py_common [4.89s]                                                                                                            
Aborted  <<< cv_bridge [16.9s]                                                                                    
Aborted  <<< message_filters [19.6s]                                    

Summary: 6 packages finished [19.8s]
  1 package failed: qt_gui_cpp
  6 packages aborted: camera_calibration_parsers cv_bridge message_filters qt_gui_app rqt_gui_py rqt_py_common
  1 package had stderr output: qt_gui_cpp
  18 packages not processed

How can I setup rqt_graph in the Isaac ROS Docker container?

Hi @HiddenNetwork

First point, have you tried the new Isaac ROS 2.0 version? We made huge updates and you don’t need to build everything! :-)

New documentation:

Our new ROS2 buildfarm:

Let me know if resolve your issue


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.