How to launch CSI camera node in the ROS launch file in Ubuntu 18.04

Dear Support,

After I have flashed the JetPack4.3 into my Jetson TX2, I have tried the following command to test my on-board CSI camera. It works.

gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink

But my following Robot Launch file no longer works to publish the CSI camera node (for the same file, it works on Ubuntu 16.04).

Can someone give me a suggestions?
Thanks so much
Jimmy

=============================







Could you tell how to launch CSI camera by robot launch?

Hi ShaneCCC,

Following is the Robot launch file which works for the JetPack3.3 (ubuntu 16.04) except that it doesn’t work for JetPack4.3 (ubuntu 18.04).

Also I have tried to replace “nvcamerasrc” with the “nvarguscamerasrc” and found both doesnot work on ubuntu 18.04.

Can you give the suggestions?

Thanks a lot

Jimmy

I didn’t have experience for the robot launch.
How do you run it and what’s the source pipeline. Have you try the pipeline by gst-launch-1.0?

Yes. the command line works except that the Robot launch file is no longer working for ubuntu 18.04.

gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink

Could you share how to run the robot launch file.