How to load pretrained model efficientnet_bx in Jetson Xiavier NX?

I tried to load pretrained model efficientnet-b7 to train my own data referring to jetson-inference in my Jetson Xiavier NX, but I got error :

Use GPU: 0 for training
=> dataset classes: 14 [‘BrightRRD’, ‘Bubble’, ‘Connection’, ‘Dirt’, ‘Fake’, ‘Gel’, ‘NoAC’, ‘PenMark’, ‘Streak’, ‘WaterDrops’, ‘Wrinkle’, ‘other3 cut’, ‘others’, ‘overexposure’]
=> using pre-trained model ‘efficientnet_b7’
Traceback (most recent call last):
File “”, line 521, in
File “”, line 143, in main
main_worker(args.gpu, ngpus_per_node, args)
File “”, line 213, in main_worker
model = reshape_model(model, args.arch, num_classes)
File “/home/nvidia/jetson-inference/python/training/classification/”, line 55, in reshape_model
print("classifier reshaping not supported for " + args.arch)
NameError: name ‘args’ is not defined

Does this mean it can’t support efficientnet for now? (I can use Resnet152 successfully)

Thanks for your comments!


This topic will get more exposure posted in the Jetson Forums.
I went ahead and moved it over for you.

Hi @hou305, I just added support for EfficientNet in in commit 819b10. If you pull the latest, it should be working now:

cd ~/jetson-inference
git pull --recurse-submodules


It works now! Thanks1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.