How to make gnc continuously available?

Please provide the following information when requesting support.

• Hardware (T4/V100/Xavier/Nano/etc) T4
• Network Type Faster_rcnn,Mask_rcnn
(Detectnet_v2/Faster_rcnn/Yolo_v4/LPRnet/Mask_rcnn/Classification/etc)
• TLT Version (Please run “tlt info --verbose” and share “docker_tag” here)
• Training spec file(If have, please share here) Tao 2,.0m toolkit_versiuon3.22.5
• How to reproduce the issue ? (This is for errors. Please share the command line and the detailed log here.)

Hello professor:
I am just starting to learn TAO toolkit. I meet a problem about GNC.
I create a conda environment, and follow the “About NGC CLI“ to down load the ngc. :NVIDIA NGC.
till to “ngc config set”. Then I can use the command ngc.

However, if I open a second terminal, and active the conda environment, but I can not use the ngc command. I need to download the ngc again.
So I hope to know, how to config the ngc, that I can use the command if I open another terminal with the same conda environment.

Thank you very much.

Where is your ngc?
$ which ngc

And, could you run “ngc config set” before you active conda environment?

Thank you very much for your response. If I use “which ngc”, there is nothing,

If command “ngc config set”, the command ‘ngc’ not found, did you mean:
command ‘gc’ from snap genesyscloud-cli(0.2)

Thank you very much

So, did you ever download ngc in your machine?
From NVIDIA NGC

wget --content-disposition https://ngc.nvidia.com/downloads/ngccli_linux.zip && unzip ngccli_linux.zip && chmod u+x ngc-cli/ngc

Thank you very much.
Yes I download the NGC as the follows

and I can login

But if I use the NGC code, I get as below

And if I use it in jupyter, the same

Please try
! /ngc-cli/ngc registry model list nvidia/tao/pretrained_object_detection:*

Thank you very much. But I got:

Try:
! ngc-cli/ngc registry model list nvidia/tao/pretrained_object_detection:*

Thank you very much.
When I try it in terminal, I got the right answer as below


However, when I run in Jupyter, I got

Please check and run below in notebook.
! pwd
! wget --content-disposition https://ngc.nvidia.com/downloads/ngccli_linux.zip && unzip ngccli_linux.zip && chmod u+x ngc-cli/ngc

Thank you very much.
I run !pwd before the other code, and I can get

Then, I added “ngc-cli/” before the command as you gave to me. and it succeed

My question is: Should I add the ! pwd and “ngc-cli/” before the command.

Yes, you can.

1 Like

Thank you very much! it works

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.