How to modify the boot order on orin nx?

Have you tried the following instruction to install edk2-pytool-extensions?
edk2-pytool-extensions/ at master · tianocore/edk2-pytool-extensions · GitHub

What I mean is to select USB disk as boot device directly through Boot Manager → select USB disk → Enter .

I’m using Ubuntu18.04, not WSL.I have tried according to the link, but it reported an error in the last step:

I’ve tried it the way you said it before, but it still starts from SSD, and I don’t know why.

I just tried it on WSL in x86 environment. They have the same problem.

How about if you remove SSD and keep only SD connected? Will it boot successfully from SD card normally?

Please just use standalone x86-64 Ubuntu 18.04 or 20.04 as your host PC.
It seems like environment issue about installing edk2-pytool-extensions.

Yes,But I use USB disk. I don’t have an SD card.If I remove SSD,it will boot successfully from USB disk.I don’t know why I can’t choose to boot directly by BIOS when boot up.

Have you tried with the following instruction to modify boot order through L4TConfiguration.dtbo?
UEFI Adaptation — Customizing the Default Boot Order in L4TConfiguration.dtbo in the BSP Directory

I have a try just now.I modify the order and download the firmware again.It still boots from SSD when SSD and USB disk are both connected.

It seems you are using R35.2.1, could you help to update to latest R35.3.1 and verify?

Do you have Orin Nano devkit to reproduce the same behavior with R35.3.1?

Yes,we are using R35.2.1.Is there a related bug in this branch? Why we need to switch to R35.3.1?

Using the latest release would be better to synchronize the status and clarify the issue with us.
Do you have Orin Nano devkit with the same issue?

It seems the boot-order working as expected with R35.3.1.

Could you also help to replace the Linux_for_tegra/bootloader/BOOTAA64.efi from R35.3.1 to R35.2.1 and flash the whole board to verify?

I tried to replace the Linux_for_tegra/bootloader/BOOTAA64.efi and Linux_for_tegra/bootloader/uefi_jetson.bin from R35.3.1 to R35.2.1.Then flash the whole board.It still doesn’t work.

For the boor-order, you might need to replace Linux_for_Tegra/kernel/dtb/L4TConfiguration.dtbo with L4TConfiguration_Jetson_RELEASE.dtbo built from you

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.