How to monitor GPU memory usage on px2

Hi,

I am running driveworks samples with drive px2.
I want to monitor how much GPU memory is being used while running multiple samples.

I checked it using tegrastats, but GR3D_FREQ and GR3D_PCI always get 0%. I also know that tegrastats does not show the memory usage of the GPU. (Nsight system tool is the same)

Running nvidia-smi I see GPU memory usage.

±----------------------------------------------------------------------------+
| NVIDIA-SMI 410.48 Driver Version: 410.48 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce RTX 2080 Off | 00000000:02:00.0 On | N/A |
| 32% 39C P8 2W / 215W | 684MiB / 7949MiB | 2% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 1404 G /usr/lib/xorg/Xorg 364MiB |
| 0 2073 G compiz 122MiB |
| 0 3557 G …AAAAAAAAAAAAAAgAAAAAAAAA --shared-files 196MiB |
±----------------------------------------------------------------------------+

Is there any way to check GPU memory usage on Drive px2?

Dear @763k357,
Unfortunately there is no nvidia-smi type command for DRIVE platform. tegrastats can measure only iGPU usage details.

I See.
So, can’t I check the gpu memory usage on the drive platform at all?

Even if I use tegrastats, iGPU, dGPU usage keeps getting 0%.
I saw in another forum article that updating this issue, is there any updated tegrastats for drive px2?

Dear @763k357,
Unfortunately there is no releases targeted for DRIVE PX2. We have fixed the issues with tegrastats on DRIVE AGX. Please consider upgrading to DRIVE AGX if possible.