How to mount my SD to my directory auto ?

Hi,

When I insert my SD card to the TX2, it will auto mount to the path /media/nvidia/xxxx . And I would want to it mount to my created directory. how can I modify the udev rules ? I can’t find the rules which mount SD to /media/nvidia/xxxx .

Thanks.

I believe this is a general Linux issue.

Please refer to external resource for more detail.

https://ubuntuforums.org/showthread.php?t=2393338

If you want a particular SD card (and not all in general) to automount, then one option is to just create a “/etc/fstab” entry naming its UUID. Be warned though, if you make the setting such that it demands the particular SD card, and the card is not present, then it may stop and wait.

There are a number of ways a device being mounted can be identified, but the UUID is unique to an exact partition. If you run “lsblk -f” you will see all of the partitions, and if the partition has a UUID (usually one is always present if there is a file system on it), it will be listed.

An example of making a vfat partition available to a specific location, but to not require it to be present:

UUID=what-ever-it-is   /some/mount/point   vfat noauto,user  0 0

If someone were to run “mount /some/mount/point”, then the right partition would be mounted. If this works for you, then you can edit the entry to remove the “noauto”.

Before you experiment with file system mounting I’ll suggest you clone a backup if you value the system. See:
https://devtalk.nvidia.com/default/topic/1000105/jetson-tx2/tx2-cloning/