How to mount USB 3.0 only device?

we would like to integrate a USB 3.0 only storage device without a USB 2.0 connection. However it does not work. We have tried to connect a USB 2.0 bus temporarily. Then the USB storage device is detected and mounted with 5000M . We then can disconnect the USB 2.0 bus and the storage device continues to work with just its USB 3.0 connection.

How can we make this storage device work with an USB 3.0 only setup? We have tried a Xavier NX with Jetpack 4.6. Can we configure the system so that not only USB 2.0 devices are enumerated but also devices which are just attached to the USB 3.0 bus? Thank you for your help.

There is no such thing because this does not follow the usb protocol.

USB3 must be run along with the USB2.

I will add that USB tends to make it possible for a higher speed device to fall back to lower speeds. Generally speaking, the device query is from lower speeds before trying higher speeds. Up through USB 2 a single chip provided both the USB 2 and older USB speeds (1.1 and 1.0). With USB 3 a dedicated controller works in combination with a legacy (USB 2 and slower) controller such that the device query picks whether routing is to the USB 2 or USB 3 controller.

The only case I know of where no USB 2 is involved is with a USB 3 device that has no slower speed compatibility (which is a function of the device, and not one of the controller). This might for example exist with some cameras which cannot function at slower speeds (I’ve seen this on stereo cameras). Even so, I think the host side uses the legacy controller to start the query.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.